Installation

From KDTWiki
Jump to: navigation, search

Dependencies

KDT has the following general dependencies:

  • Python 2.4 or higher with development libraries installed.
  • MPI. We recommend MPICH2, but OpenMPI and others work as well.
  • C++ headers from TR1 or C++11. GCC has had sufficient support for years, but these are also available through Boost.

Most systems come with most or all of these requirements already satisfied out of the box.

Instructions

Installation Stories

The following pages show what was required to actually install KDT on a particular machine. These are not meant to be generic guides, but they can be a source of tips or suggestions if you run into issues with your own installation.

Please let us know how your own installation went on our Feedback page.

Personal tools
Namespaces
Variants
Actions
KDT
Toolbox